OpenRoads Designer CONNECT Edition SDK Help

CalculateClothoid Method

Calculate a Geopak clothoid

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static void CalculateClothoid( DPoint3d* intrinsicPoint,double* direction,double* parameter,int  clotType, DPoint3d startPoint, DPoint3d endPoint,double startDir,double endDir,double length,double radius1,double radius2)

Parameters

SettingDescription
  DPoint3d* Intrinsic point
  * direction of the clothoid x axis
  * Clothoid parameter
   Clothoid type
  DPoint3d Start point
  DPoint3d End point
   Start direction
   End direction
   Length
   Start radius (0 = infinite)
   End radius (0 = infinite)

See Also